[Nasm-bugs] [Bug 3392383] building with watcom is broken

no-reply at bugzilla-nasm.gorcunov.org no-reply at bugzilla-nasm.gorcunov.org
Tue Feb 28 22:23:15 PST 2017


--- Comment #8 from sezeroz at gmail.com ---
(In reply to H. Peter Anvin from comment #7)
> When you say master branch, which HEAD is you specifically referring to?

Main branch which has the 2.13rc5 tag for the moment

> The warnings on lines 1067 and 1069 are extremely concerning, they make me
> believe that OpenWatcom is plain miscompiling this code.  I just reorganized
> the code slightly for performance, it *might* help but I can't really tell
> for sure.
> However, if OW's handling of 64-bit numbers really is completely broken then
> there isn't much hope of ever getting it to work right, even if we can coax
> it into building.

The added UINT64_C() are fine. (And the warnings might be false: they happen
with ow1.9 but not with the ow2.0 fork.)

Still not there though:

1. include/compiler.h: you need to do s/__WATCOM__/__WATCOMC__/

2. MkFiles/openwcom.mak needs further love I missed (sorry.) Updated it
according to Makefile.in and it works now. (patch attached.)

3. After [1] and [2], one gets from ow1.9 (but not from ow2.0) :
./include/compiler.h(262): Warning! W124: Comparison result always 0
from every file.
You say it yourself in commits 9b4b92b, e3cd70b and be01d49 that the
added hack is a truly vile and ugly and despicable hack. Removing them
and changing the two offending switch statements with 64bit values
işnto simple if/else's would be much cleaner.

You are receiving this mail because:
You are on the CC list for the bug.
You are watching all bug changes.

More information about the Nasm-bugs mailing list