[Nasm-bugs] [Bug 3392280] Dependency generation -MF flag not implemented

no-reply at bugzilla-nasm.gorcunov.org no-reply at bugzilla-nasm.gorcunov.org
Sun Jul 30 01:11:23 PDT 2017


Michael Forney <mforney at mforney.org> changed:

           What    |Removed                     |Added
                 CC|                            |mforney at mforney.org
      Obtained from|                            |Built from git using
                   |                            |configure

--- Comment #6 from Michael Forney <mforney at mforney.org> ---
I'm still noticing some strange behavior with -MD with the latest git version.

If I run

  nasm -M -f elf64 -o utils.o utils.asm

I see

  utils.o: utils.asm x86inc.asm

on stdout which looks correct, but no utils.o is generated.

If I run

  nasm -M -MD utils.o.d -f elf64 -o utils.o utils.asm

utils.asm is generated correctly, and utils.o.d is created, but it contains

  utils.o: utils.asm

which is missing any of the actual include dependencies.

I tried to look through the source to figure out why the dependencies got
omitted with -MD, but was very confused by all the pass* variables.

You are receiving this mail because:
You are watching all bug changes.

More information about the Nasm-bugs mailing list