[Nasm-bugs] [Bug 3392537] New: Codeview not valid with win64

noreply-nasm at gorcunov.org noreply-nasm at gorcunov.org
Sun Dec 23 14:46:21 PST 2018


            Bug ID: 3392537
           Summary: Codeview not valid with win64
           Product: NASM
           Version: 2.14.xx
          Hardware: All
                OS: Windows
            Status: OPEN
          Severity: normal
          Priority: Medium
         Component: Assembler
          Assignee: nobody at nasm.us
          Reporter: PICguy at hmtown.com
                CC: chang.seok.bae at intel.com, gorcunov at gmail.com,
                    hpa at zytor.com, nasm-bugs at nasm.us
     Obtained from: Binary from nasm.us

Minor(?) Bug/typo

NASM version 2.14.01 compiled on Dec 22 2018

NASM -f win64 -v
valid debug formats for 'win64' output format are ('*' denotes default):
    cv8       Codeview 8
Perhaps the ‘8’ after ‘Codeview’ was susposed to be ‘*’ for default?

NASM zzz.asm -Ox -f win64 -F Codeview -g -o zzz.obj -l zzz.lst
nasm: fatal: unrecognized debug format `Codeview' for output format `win64'
type `nasm -h' for help
Something is inconsistent. This one could be called a bug.

Something strange. NASM or Microsoft or the nut behind the screen?

I am using Windows 10. And trying to use Visual Studio 2017 where I can
presumably debug assembly code with single instruction stepping. I finally got
VS to attempt linking with my .obj file, however I had undefined externals:

Severity        Code    Description     Project File    Line    
Error   LNK2019 unresolved external symbol rand10WInit referenced in function
main      conApp1 g:\vs\conApp1\conApp1\conApp1.obj       1       
Error   LNK2001 unresolved external symbol rand10WInit  conApp1
g:\vs\conApp1\conApp1\zzz.obj   1       
Error   LNK2001 unresolved external symbol mixWord      conApp1
g:\vs\conApp1\conApp1\zzz.obj   1       
Error   LNK2001 unresolved external symbol mix  conApp1
g:\vs\conApp1\conApp1\zzz.obj   1       
Error   LNK1120 3 unresolved externals  conApp1
g:\vs\conApp1\x64\Debug\conApp1.exe     1       

Undefined rand10Init is not from the novice mistake of failing to use extern
“C” void rand10WInit(void); In C++ source.

The symbols mix and mixWord are local symbols that still were seen by the VS
linker as something of more than passing importance. I wanted debug info in my
.obj but tried building without debug info. I got the same error with mix and

Any ideas?

This is the wrong place to ask anything serious about Visual Studio, but if
anybody knows a magic trick that makes VS work the way I like please let me
know about it.

You are receiving this mail because:
You are on the CC list for the bug.
You are watching all bug changes.

More information about the Nasm-bugs mailing list