[Nasm-bugs] [Bug 3392685] dav1d build for Firefox fails to build on macOS using Homebrew NASM 2.15.01

noreply-nasm at dev.nasm.us noreply-nasm at dev.nasm.us
Mon Jun 29 12:16:52 PDT 2020


Ricky Stewart <rstewart at mozilla.com> changed:

           What    |Removed                     |Added
                 CC|                            |rstewart at mozilla.com

--- Comment #2 from Ricky Stewart <rstewart at mozilla.com> ---
Hi -- maybe I'm missing something, sorry, but I couldn't get this to work.

* When I tried this with the latest `nasm`, the failure happens before it can
apparently even produce the `.lst` file. I get the following error output and
while the `cpuid.lst` file exists on disk after the command fails, the file is

nasm(65150,0x10fef4dc0) malloc: can't allocate region
:*** mach_vm_map(size=140432626442240, flags: 100) failed (error code=3)
nasm(65150,0x10fef4dc0) malloc: *** set a breakpoint in malloc_error_break to
out of memory!

* When I tried with the previous version of `nasm`, I get an error: `nasm:
error: unrecognised option `-L'` (I assume this option is new for 2.15)?

Is there something else I can do here? Maybe I can try with the old version of
`nasm` but without `-L+`?

You are receiving this mail because:
You are watching all bug changes.
You are on the CC list for the bug.

More information about the Nasm-bugs mailing list