[Nasm-bugs] [Bug 3392538] double free or corruption (fasttop) 2.14.01 on most errors and warnings

noreply-nasm at gorcunov.org noreply-nasm at gorcunov.org
Mon Dec 24 12:13:07 PST 2018


--- Comment #7 from russvz at comcast.net ---
No, I am not running with a sanitizer. I installed the already-built NASM from
NASM's website, the same way I always do. In fact the NASM web site even
provides it with the installation program, so I just downloaded it and ran
"yum" to install it in CENTOS.

I have no problems with the previous release of NASM, 2.14, installed the same
way. In fact since I encountered the bug, I already uninstalled 2.14.01 (with
the pre-built installation), verified that I had no problems assembling the
same programs with 2.14, and then reinstalled 2.14.01 so I could continue
testing and report the bug.

So the installation steps are:

1) From the main NASM website :


2) Click on "2.14.01" in the "stable" line and under the words "Latest version"

3) In this screen, click on "Linux"


4) In this screen,


5) Click on "nasm-2.14.01-0.fc27.x86_64.rpm". Once the file downloaded, which
is an installation file for the Red Hat family of operating systems, I let it
auto-install with the "yum install" command. I downloaded the documentation in
the same way and that installed cleanly too.

6) Then after encountering the bug, I used Red Hat's installation program to
uninstall 2.14.01, reinstall NASM 2.14 downloaded from the NASM website in the
same way, verified it worked, then uninstalled 2.14, reinstalled 2.14.01 and
had the same problem.

WORKAROUND: Thank you for attempting to reproduce the problem. It seems like
the best approach is for me to drop back to NASM 2.14 temporarily. Then I can
try to find out if anything else in my environment could be causing a problem,
and you all can see if anyone else reports the problem.

The thing is that I don't have a lot of hope about finding anything. Because I
even tried running NASM manually from the command line to see if anything on my
side could be causing it. I also switched from the 800-line program which I was
testing, tried that small "hello, world" program which I sent you, and verified
I had the same problem.

You are receiving this mail because:
You are watching all bug changes.
You are on the CC list for the bug.

More information about the Nasm-bugs mailing list